
 

Data and Information 

 Data: 
 

 Data is the collection of raw facts and figures. 
 

 It has no proper meaning until it is processed. 
 

 It can be numbers, words, symbols, or pictures. 
 

 Example: 85, 90, 75, Ajay, 102. 
 

 Information: 
 

 When data is processed, organized, and presented in a meaningful way, it 

becomes information. 

 Information is useful for decision-making. 
 

 Example: Ajay (Roll No 102) scored 85, 90, and 75 in three subjects. 
 

👉 Relation: Information = Data + Processing + Meaning 

 

Databases and DBMS 

 Database: 
 

 A database is an organized collection of related data stored in a structured 

format. 

 The data is arranged in tables (rows and columns). 
 

 Example: Student Database with fields like Roll No, Name, Class, Marks. 
 

 DBMS (Database Management System): 
 

 DBMS is software that helps in creating, storing, managing, and retrieving data 

from a database. 

 It provides tools to add, update, delete, and search data easily. 
 

Examples of DBMS: LibreOffice Base, MS Access, MySQL, Oracle, SQL Server. 

Main functions of DBMS: 

1. Data Storage – Stores large amounts of data safely. 
 

2. Data Retrieval – Fetches specific information quickly using queries. 
 

3. Data Manipulation – Insert, update, and delete records easily. 
 



 

4. Data Security – Protects data from unauthorized access. 
 

5. Data Integrity – Maintains accuracy and consistency. 
 

6. Backup and Recovery – Restores data if lost. 
 

7. Multiple User Access – Many users can use the database at the same time. 
 

 

Advantages of Database (Over File System) 

Earlier, people used the file system to store data. But it had problems like data duplication, 

difficulty in searching, and no proper security. DBMS solved these issues. 

Advantages of DBMS: 

1. Reduced Data Redundancy – Data is stored only once, not repeated. 
 

2. Data Consistency – Same data is available for all users, no mismatch. 
 

3. Data Security – Password protection and user access rights are available. 
 

4. Easy Backup and Recovery – Lost data can be restored easily. 
 

5. Multi-user Access – Many users can use the same database at the same time. 
 

6. Efficient Searching – Queries make searching very fast. 
 

7. Data Sharing – Data can be shared among different applications. 
 

 

Data Models 

👉 A data model is a way to organize and represent data in a database. It shows how data is 

connected and how it will be stored. 

(i) Hierarchical Data Model 

 Data is stored in a tree-like structure. 
 

 It follows Parent-Child relationship. 
 

 Each child can have only one parent, but a parent can have multiple children. 
 

 Example: Company → Departments → Employees. 
 

👉 Advantages: Easy for one-to-many relationships, fast access. 

 👉 Disadvantage: Difficult to modify structure, not flexible. 

 
(ii) Network Data Model 



 

 Data is stored in records and connected using links (pointers). 
 

 Each record can have multiple parent and child records. 
 

 Allows many-to-many relationships. 
 

 Example: Students ↔ Courses (One student can take many courses, and one course can 

have many students). 

👉 Advantages: Flexible and handles complex relationships. 

 👉 Disadvantage: Structure is complicated, difficult to maintain. 

 
(iii) Relational Data Model 

 Data is stored in the form of tables (rows and columns). 
 

 Each table is called a Relation. 
 

 Very simple and widely used model in modern databases. 
 

 Example: Student Table → Roll No, Name, Marks. 
 

👉 Advantages: Easy to use, flexible, supports queries. 

 👉 Disadvantage: Slower for very large databases compared to hierarchical. 

 

Relational Database Model (RDBMS) 

A Relational Database Management System (RDBMS) stores data in tables and maintains 

relationships between them. It is the most popular type of DBMS used today. 

(a) RDBMS Terminology 

1. Table (Relation): Collection of data in rows and columns. 
 

2. Row / Record / Tuple: A single complete entry in the table. Example: (101, Ajay, 95). 
 

3. Column / Field / Attribute: A property of data. Example: Roll No, Name, Marks. 
 

4. Primary Key: A field that uniquely identifies each record. Example: Roll No. 
 

5. Foreign Key: A field that links two tables. Example: Class ID in Student Table linking to 

Class Table. 

6. Query: A tool to ask questions and get answers from the database. 
 

7. Form: User-friendly way of entering and editing data. 
 



 

8. Report: Used to display and print data in a formatted manner. 
 

 
(b) Objects of an RDBMS 

1. Tables: Store the actual data in rows and columns. 
 

2. Queries: Retrieve, filter, and sort data. 
 

3. Forms: Provide a simple way to input and update data. 
 

4. Reports: Present information in a readable and printable format. 
 

Introduction to LibreOffice Base 

 LibreOffice Base is a Database Management System (DBMS) software. 
 

 It is used to create, store, manage, and retrieve data in an organized way. 
 

 Base helps you enter data, organize it, query it, and present it in reports. 
 

 LibreOffice Base is free, open-source, and works on Windows, Linux, and macOS. 
 

Why we use LibreOffice Base: 

1. To store large amounts of data safely in tables. 
 

2. To find information quickly using queries. 
 

3. To enter and update data easily using forms. 
 

4. To generate reports for analysis or printing. 
 

Example: A school can use LibreOffice Base to maintain a Student Database with Name, Roll 

No, Class, Marks, etc. 

 

Data Types in LibreOffice Base 

Every field (column) in a table must have a data type. It determines what kind of data can be 

stored. 

Data Type Description Example 

Text (VARCHAR) Letters, numbers, symbols Name, Address 

Integer Whole numbers Roll No, Age 



 

Decimal / Float Numbers with decimals Marks, Price 

Date Dates 13-09-2025 

Time Time values 10:30 AM 

Boolean / Yes-No True/False or Yes/No Pass/Fail 

 
Tip: Choosing the correct data type helps in preventing errors and maintaining data integrity. 

 

Starting LibreOffice Base 

Steps to start LibreOffice Base: 

1. Open LibreOffice → Click Base icon. 

 
2. You will see a Database Wizard: 

 

 Option 1: Create a new database → Start from scratch. 
 

 Option 2: Open an existing database → Work with saved data. 
 

3. The wizard guides you step-by-step to create a database. 
 

 

User Interface of LibreOffice Base 

The Base window has several sections: 

1. Menu Bar: Contains commands like File, Edit, View, Tools. 
 

2. Toolbar: Quick access to New, Open, Save, Print, etc. 
 

3. Database Objects Pane (Left side): Shows: 
 

 Tables 
 

 Queries 
 

 Forms 
 

 Reports 
 

4. Workspace (Right side): The area where you work with tables, forms, queries, or 

reports. 



 

5. Status Bar: Displays info about the database and selected object. 
 

Tip: Learn the icons – e.g., New Table, Run Query, Form Wizard – it makes work faster. 

 

Opening a Database 

 To open a saved database: 
 

1. Click File → Open 
 

2. Select the .odb file from your computer 
 

3. The database opens in the LibreOffice Base window 
 

 After opening, you can view tables, queries, forms, and reports. 
 

 

Creating a Table 

A table stores all the data in a database in rows (records) and columns (fields). 

(a) Using Table Wizard 

The Wizard is a beginner-friendly method. 

Steps: 

1. Go to Tables → Use Wizard to Create Table 
 

2. Select fields from the suggested list (e.g., Name, Roll No, Marks) 
 

3. Arrange the fields in proper order 
 

4. Set data types and sizes automatically 
 

5. Click Finish → Table is created 
 

Example: Student Table 

| Roll No | Name | Class | Marks | 

 
(b) Using Design View 

Design View is an advanced method giving full control over table structure. 

Steps: 

1. Go to Tables → Create Table in Design View 
 

2. Add fields (columns) one by one: 
 



 

 Field Name: Roll No → Data Type: Integer 
 

 Field Name: Name → Data Type: Text 
 

 Field Name: Marks → Data Type: Decimal 
 

3. Set Field Properties: size, default value, validation rules 
 

4. Set Primary Key if required (unique identifier for records) 
 

5. Save the table with a suitable name 
 

 

Setting Primary Key 

 Primary Key ensures that each record in the table is unique. 

 Usually used on fields like Roll No, Employee ID, etc. 
 

Steps to set Primary Key: 

1. Open table in Design View 
 

2. Select the field (e.g., Roll No) 
 

3. Right-click → Select Primary Key 

 

4. A key icon appears next to the field → Primary key set 
 

Why Primary Key is important: 
 Prevents duplicate records 

 
 Helps in creating relationships between tables 

 

 

Saving a Table 

 After creating a table, it must be saved. 
 

Steps: 

1. Click File → Save 
 

2. Enter a Table Name (e.g., Student) 
 

3. Click OK → Table is saved 
 

Tip: Always save before closing LibreOffice Base to avoid losing data. 

 

Example of Table Creation (Step by Step) 



 

1. Open LibreOffice Base → Create new database → Save 
 

2. Go to Tables → Use Wizard to Create Table 
 

3. Select fields: Roll No, Name, Class, Marks 
 

4. Click Next, arrange fields, set data types 
 

5. Set Primary Key = Roll No 
 

6. Click Finish, table is created 
 

7. Enter sample data: 
 

Roll No Name Class Marks 

101 Ajay 10A 95 

102 Deepak 10B 88 

103 Ramesh 10A 90 

 

Entering Data into a Table 

 After creating a table, you need to enter data (records). 
 

 Each row = one record, each column = one field. 
 

Steps to enter data: 

1. Open the table by double-clicking its name in the Tables pane. 
 

2. The table opens in Data View (also called Table View). 
 

3. Click on the first empty row. 
 

4. Type the data for each field. 
 

 Example: Roll No → 101, Name → Ajay, Class → 10A, Marks → 95 
 

5. Press Enter or Tab to move to the next row. 
 

Tips: 

 Always enter data in the correct column type. 
 



 

 Example: Don’t type text in a number field. 
 

 Base automatically saves each record after entering. 
 

 

Navigating Through the Table 

 When a table has many records, you need to move through the table efficiently. 
 

Navigation Options: 

1. Arrow Keys: Move one cell up, down, left, or right. 
 

2. Tab Key: Move to the next field in the same record. 
 

3. Shift + Tab: Move to the previous field. 
 

4. Navigation Bar (Bottom of Table View): 
 

 First Record: Goes to the first record 
 

 Previous Record: Moves one record up 
 

 Next Record: Moves one record down 
 

 Last Record: Goes to the last record 
 

 New Record Button (+): Add a new record 
 

Tip: Navigation bar is very useful when working with large tables. 

 

Editing Data in a Table 

 Sometimes you need to update or correct data in the table. 
 

Steps to edit a record: 

1. Open the table in Data View. 
 

2. Click on the cell you want to edit. 
 

3. Type the new value. 
 

4. Press Enter → Base automatically saves the change. 

 
Example: 

 Original: Marks = 88 
 

 Edit: Marks = 90 → Updated automatically 
 

Tip: Be careful when editing primary key values, as it may affect table relationships. 

 



 

Deleting Records from a Table 

 To remove unwanted or incorrect records from a table: 
 

Steps to delete a record: 

1. Select the entire row of the record to delete. 
 

2. Right-click → Select Delete Record 

 

3. A confirmation message appears → Click Yes 

 
4. Record is removed permanently from the table 

 
Tip: Deleted records cannot be recovered unless you have a backup. 

 

Sorting Data in a Table 

 Sorting helps to arrange records in ascending or descending order. 
 

Steps to sort data: 

1. Open the table in Data View. 
 

2. Select the column to sort (e.g., Marks). 
 

3. Click Data → Sort Ascending → Lowest to highest 
 

4. Click Data → Sort Descending → Highest to lowest 
 

Example: Sorting students by Marks: 
 Ascending: 75, 85, 90, 95 

 
 Descending: 95, 90, 85, 75 

 
Tip: 

 Sorting does not delete records, it only rearranges the view. 
 

 You can sort by multiple columns (e.g., Class first, then Marks). 

 

 

 

Editing and Deleting Tables 

 



 

Editing a Table 

 Sometimes you need to change the structure of a table (add/remove fields, change 

data types, etc.). 

 Steps to edit a table: 
 

1. Open LibreOffice Base → Go to Tables pane. 

 

2. Right-click on the table → Select Edit 

 
3. You can: 

 
 Add new fields (e.g., add “Email” column) 

 
 Change field names or data types 

 
 Reorder fields if needed 

 

4. Save changes → Table is updated 
 

Deleting a Table 

 To permanently remove a table from the database: 
 

1. Go to Tables pane 
 

2. Right-click on the table → Select Delete 

 

3. Confirm deletion → Table is removed permanently 
 

Tip: Always backup the database before deleting tables. 

 

Relationships Between Tables 

 A relationship links two or more tables to show how their data is connected. 
 

 Helps avoid duplicate data and maintain data consistency. 
 

Example: 

 Student Table: Roll No, Name, Class 
 

 Class Table: Class ID, Class Name, Teacher 
 

 Relationship: Student.Class → Class.Class ID 
 

 

Types of Relationships 



 

(a) One-to-One (1:1) 

 One record in Table A is related to only one record in Table B. 
 

 Example: 
 

 Student → Student ID 
 

 Student Profile → Each student has only one profile 

 

(b) One-to-Many (1:N) 

 One record in Table A is related to many records in Table B. 
 

 Example: 
 

 Class → Class ID 
 

 Student → Many students belong to one class 

 
 Most common type of relationship in databases 

 

(c) Many-to-Many (M:N) 

 Many records in Table A are related to many records in Table B. 
 

 Example: 
 

 Student ↔ Courses 
 

 One student can take many courses, and one course can have many students 
 

 Requires a junction table to manage the relationship 
 

 

Advantages of Relating Tables 

1. Avoid Data Redundancy: Store information only once 
 

2. Ensure Data Consistency: Changes in one table automatically reflect in related tables 
 

3. Easier Data Management: Add, delete, or update data without affecting other tables 
 

4. Faster Queries and Reports: Fetch related information easily 
 

5. Better Organization: Data is structured and clear 
 

 

 



 

Creating Relationships Between Tables in LibreOffice 

Base 

Steps: 

1. Open the database → Go to Tools → Relationships 
 

2. The Relationships window opens → All tables are listed 
 

3. Drag the field from Table A (e.g., Class ID) → Drop it onto the related field in Table B 

 

4. The Edit Relationship dialog appears → Check settings: 
 

 Enforce Referential Integrity 
 

 Choose Relationship type: One-to-One or One-to-Many 
 

5. Click OK → Relationship is created 
 

Example: 

 Drag Class ID from Class Table → Drop onto Class field in Student Table → One-to-

Many relationship 

 

 

Referential Integrity 

 Referential Integrity ensures that relationships between tables remain consistent. 

 Rules: 
 

1. You cannot delete a record from the primary table if it has related records in another 
table 
 

2. You cannot enter a value in the foreign key field that does not exist in the primary table 
 

3. It ensures data accuracy and consistency across related tables 
 

Example: 

 Student Table → Class field (foreign key) 
 

 Class Table → Class ID (primary key) 
 

 Referential Integrity prevents a student from being assigned to a non-existent class 



 

Introduction to Queries 

 A Query is a tool to retrieve specific information from one or more tables in a 

database. 

 It acts like a question to the database: “Give me all students with marks above 90.” 
 

 Important: Queries do not change the original table, they just display filtered or 

sorted data. 

 

Uses of Queries: 

1. Filter data based on conditions 
 

2. Sort data in ascending or descending order 
 

3. Perform calculations on numerical data (like sum, average) 
 

4. Combine data from multiple tables 
 

 

Creating a Query Using Query Wizard 

Query Wizard is the easiest way to create queries step-by-step. 

Steps: 

1. Open database → Go to Queries → Use Wizard to Create Query 
 

2. Select Table or Query as the data source (e.g., Student Table) 
 

3. Select Fields to include (e.g., Roll No, Name, Marks) 
 

4. Set Filter criteria (optional) 
 

 Example: Marks > 90 
 

5. Choose Sort order (optional) 
 

 Example: Sort by Marks descending 
 

6. Name the query and click Finish 
 

7. Query result shows the filtered or sorted data 
 

Tip: The wizard is user-friendly and best for beginners. 

 

Creating a Query Using Design View 

Design View gives more control and flexibility for advanced queries. 



 

Steps: 

1. Go to Queries → Create Query in Design View 
 

2. Add tables you want to use in the query 
 

3. Drag fields from tables into the query grid 
 

4. Set criteria in the “Criteria” row 
 

 Example: Marks > 90 
 

5. Set sort order in the “Sort” row 
 

6. Save and run the query 
 
 
 
Example Grid: 

 

Field Table Criteria Sort 

Name Student   

Marks Student >90 Desc 

 

Editing a Query 

 To change an existing query: 
 

1. Open the Queries pane 
 

2. Right-click the query → Select Edit 

 
3. Modify fields, criteria, or sort order as needed 

 

4. Save the changes → Run the query to see updated results 
 

Tip: Editing queries does not affect the original table. 

 

Working with Numerical Data in Queries 

 Queries can perform calculations on numerical data. 
 

Common Operations: 



 

1. Sum: Total of all values in a column 
 

2. Average: Mean of numerical values 
 

3. Count: Number of records that meet a condition 
 

4. Min / Max: Find smallest or largest value 
 

Example: 

 Query: Average Marks of students in Class 10A 
 

 Steps: 
 

1. Add Marks field 
 

2. Choose Function → Average 
 

3. Set criteria (Class = 10A) 
 

4. Run query → Result shows average marks 
 

 

 
Forms in Base 

 A Form is a user-friendly interface for entering, viewing, and editing data in a 

database. 

 Forms make it easier to add records without opening the table directly. 
 

 Forms can include: text boxes, drop-down lists, buttons, checkboxes, etc. 
 

Uses of Forms: 

1. Simplify data entry 
 

2. Reduce errors by restricting input types 
 

3. Make database more interactive and professional 
 

 

Creating a Form Using Wizard 

Form Wizard allows beginners to create forms step-by-step. 

Steps: 

1. Go to Forms → Use Wizard to Create Form 
 

2. Select Table or Query as data source 
 



 

 Example: Student Table 
 

3. Select fields to include in form (e.g., Roll No, Name, Marks) 
 

4. Choose layout style (Columnar, Tabular, etc.) 
 

5. Set form title 
 

6. Click Finish → Form is created 
 

7. The form opens → You can enter new records easily 

 
Tip: Columnar layout is most common for data entry forms. 

 

Modifying a Form 

 Forms can be customized in Design View to improve appearance or add functionality. 

Steps to modify a form: 

1. Right-click the form → Select Edit 

2. Add/remove fields, move controls, resize text boxes 
 

3. Change font, color, and style of labels and fields 
 

4. Save the modified form 
 

Tip: Always test the form by entering a few records to ensure it works properly. 

 

Form Controls Toolbar 

 The Form Controls Toolbar provides tools to add interactive elements: 

 

Control Use 

Text Box Input or display text 

Label Display field name 

Combo Box Drop-down list selection 

Check Box Yes/No input 



 

Option Button Multiple-choice selection 

Command Button Perform actions (e.g., save 
record) 

Tip: These controls improve data entry accuracy and speed. 

 

Reports in Base 

 A Report is used to present database information in a readable and professional 

format. 

 Reports are mainly for printing or sharing data. 
 

Uses of Reports: 

1. Summarize information from one or more tables 
 

2. Include titles, headings, and formatted data 
 

3. Display totals and calculations 
 

 

Inserting Other Controls in Reports 

 In Report Design View, you can add: 
 

1. Text boxes → Show field values 
 

2. Labels → Describe fields 
 

3. Lines or rectangles → Separate sections visually 
 

4. Images or logos → School logo or watermark 
 

Tip: Adding controls makes the report more professional and easier to read. 

Inserting Titles & Headings in Reports 

 Titles and headings make reports organized and clear. 
 

Steps: 

1. Open the report in Design View 
 

2. Use the Label control from Form Controls toolbar 
 

3. Type the title or heading (e.g., “Student Marks Report”) 
 



 

4. Change font size, color, and style for visibility 
 

 
 

Inserting Date & Time in Reports 

 Date and time provide context for reports. 
 

Steps: 

1. In Design View → Insert → Field → Date/Time 
 

2. Select format (e.g., DD-MM-YYYY or HH:MM AM/PM) 
 

3. Position it in the header or footer 
 

Tip: Including date/time is useful for official reports and printing. 
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